Jump to content
  • 0
Sign in to follow this  
Jeff

Clipboard Module

Question

34 answers to this question

Recommended Posts

  • 0

Thanx Jeff for introducing our project. Yes, it is very young project which needs some testings although we know some glitches. But I believe thanx to Robert's (Ylee) professional approach and admirable skills we will get over them and offer another nice stuff for Bodhi community :)

 

PS: any devel help is appreciated

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

I am not at all sure this module is ready for "prime time", but it certainly needs some people to test its functionality and stability. I am doing way more coding than testing. However much I agree with the idea of Test-driven development, never really quite understood how to apply unit tests to GUI development much less enlightenment modules. Some functions needed yes but anyways I digress...

 

I flat out expect some issues, I know of several myself altho one would be not noticeable to the end user, also not a big deal either. A fix for that one I will commit soon. 

 

So thanks Jeff for packaging it and adding it to the repos. That certainly is a way to get people to tests its functionality against a wide range of software and usage patterns :) Stefan or me either one was going to package it whenever I thought it was stable enough to call an Official Beta release. Me being somewhat of a perfectionist who knows when that would have been. Stefan on the other hand has been wanting to package it and announce here for a few weeks.

 

By the way I love that line in the screenshot: "SEGFAULT is not appropriate error handling." Oh the joys of c programming :( 

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

So far the only bug I've noticed, is that I have to copy everything twice before it will paste. This occurs in WPS office, Firefox, Epad and about everywhere else.

Share this post


Link to post
Share on other sites
  • 0

Hmm, do not understand. If you select a text and copy with CTRL C or from context menu, it does not add to clipboard history? I have no problem with this. If possible, can you be more specific to reproduce your issue here?

Share this post


Link to post
Share on other sites
  • 0

If I have the module on, I have to click the right context menu "copy" twice on a selection before it will paste. I don't have that issue if I use ctrl+c, If I turn off the module all is normal.

Share this post


Link to post
Share on other sites
  • 0

So far the only bug I've noticed, is that I have to copy everything twice before it will paste. This occurs in WPS office, Firefox, Epad and about everywhere else.

 

I haven't tested against wps office briefly against Ff but it should work perfect in e-pad. All testing is done against the default theme. So my question is what theme are you using? If it is not the default theme change themes to default and test again. If the issue persist unload the module and to be certain everything is freed cleared and so on reboot. Now load the module and test again. 

 

I have not tested against any theme but the default. Any theme that borks the module is in some sense broken if it works using the default theme. That is my philosophy  on coding this module.

Share this post


Link to post
Share on other sites
  • 0

I am not having to copy twice here with the clipboard module under the moonlight or radiance themes. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hmm, I removed the Clipboard gadget from the shelf and let only module work and still no issues under Green theme. Randy: try to delete history file located in .local/share/clipboard and all config files in .e/e/config/bodhi/module.clipboard*. We will see if this can help...

 

Stefan

 

BTW: our project is some commits ahead against package in repository and some glitches had been solved there. I am not sure it is related to your troubles, though. Anyway could be worth trying... 

Share this post


Link to post
Share on other sites
  • 0

I have a mix of about 3  themes.  Agenesis2 , Default, Moksha Radience. If I can remember how to reset them to where they are I will reset the theme and retest clipboard. I have a feeling Ylee's right about the theme. Probably the Agenesis2. I will also do as Stephan asked after I reset the theme if that does not work.

Share this post


Link to post
Share on other sites
  • 0

I one by one changed themes and also deleted the files Stephan requested. But the bug still persists. If I use the keyboard all works as should. But If I use the right click context with the mouse I have to click copy twice before it will paste. If I'm the only one having this issue, then it must be something to do with my personal setup of Bodhi. But at least if it comes up again from another user you'll have prior knowledge. And then it might warrant further investigation.

Share this post


Link to post
Share on other sites
  • 0

Which applications is the right click menu needing to be used twice? Just one or all of them? What happens when you de-select the text after using the copy in the menu?

Share this post


Link to post
Share on other sites
  • 0

Hmm, interesting. Try to copy .e folder somewhere as backup and delete this folder. Log out and log in. Although your setting is gone, you have got an empty desktop ready for testing. If it wont help, just return backup folder back. Another solution is installing bodhi under virtual box and trying module in the clear installation. Maybe this info will help you

Share this post


Link to post
Share on other sites
  • 0

Which applications is the right click menu needing to be used twice? Just one or all of them? What happens when you de-select the text after using the copy in the menu?

It happens in all applications. De-selecting text works like it should.

 

 

Hmm, interesting. Try to copy .e folder somewhere as backup and delete this folder. Log out and log in. Although your setting is gone, you have got an empty desktop ready for testing. If it wont help, just return backup folder back. Another solution is installing bodhi under virtual box and trying module in the clear installation. Maybe this info will help you

It is mostly just an annoyance. I can use the keyboard. I am partial to my setup and even if it is an e setting I'd rather live with it than turn something off. If this ever shows up as a problem for someone else, I will make it a priority to help hunt it down. My luck it's probably the glass icon set I'm using or the touchpad-indicator I use to turn of the touchpad when I use a regular mouse.

 

Edit: Just an additional note. I installed parcilite clipboard manager, and it works normally. And it's not the icon set.

Share this post


Link to post
Share on other sites
  • 0

So to confirm - if you copy text using the right click menu, and then deselect said text it appears in the clipboard tool properly without having to use the copy menu again?

 

If you back up your .e folder you can always put your existing settings easily back by simply moving it back to where it was after debugging ;)

Share this post


Link to post
Share on other sites
  • 0

So to confirm - if you copy text using the right click menu, and then deselect said text it appears in the clipboard tool properly without having to use the copy menu again?

 

If you back up your .e folder you can always put your existing settings easily back by simply moving it back to where it was after debugging ;)

Yes it copies to the clipboard tool no problem. It is just not available to paste until I copy again. And if I click on it in the modules history it still is not available to paste with the mouse.

 

Ok  I'll back up and try with new .e

Share this post


Link to post
Share on other sites
  • 0

@Randy, I am currently out of town and while I have my little netbook with me it is not optimal for dev work and besides I am prior obligations here. But anyways i am interested in whatever is causing this issue you are having. I was unable to reproduce it but if you determine it is not something borked in your .e profile maybe we can work together latter on ... this weekend or next week or something to help debug this. Even if it is caused by your e settings unless they are 'corrupt' I would like to get to the exact cause of the issue.

Share this post


Link to post
Share on other sites
  • 0

@Randy, I am currently out of town and while I have my little netbook with me it is not optimal for dev work and besides I am prior obligations here. But anyways i am interested in whatever is causing this issue you are having. I was unable to reproduce it but if you determine it is not something borked in your .e profile maybe we can work together latter on ... this weekend or next week or something to help debug this. Even if it is caused by your e settings unless they are 'corrupt' I would like to get to the exact cause of the issue.

I just tried a new .e directory and the problem still persists.  I will do whatever I can to help just let me know when. And with resetting e the only thing I changed from the default setup was to turn on the clipboard module, and add it to the shelf.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I'm glad I thought to make a custom profile. When I copied my old .e back it still loaded the default bodhi profile. It didn't save my settings.

Share this post


Link to post
Share on other sites
  • 0

I just tried a new .e directory and the problem still persists.  I will do whatever I can to help just let me know when. And with resetting e the only thing I changed from the default setup was to turn on the clipboard module, and add it to the shelf.

 

I will msg ya on here sometime after i get home.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Great to hear. Let us know.

BTW, we are also looking for po translators. If anyone is interested, we will be happy. Only English and Slovak are available now.

Share this post


Link to post
Share on other sites
  • 0

Randy, try going into settings on the clipboard module... Left-click then go to the settings tab and put a tick in Primary Selection at top in the options field for how you want the clipboard to save items. It should help, I did that, it seems to be that by default it saves primarily when you control +C, however, after doing that it works perfectly for me. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×