Jump to content
  • 0
Sign in to follow this  
robot774

[SOLVED] https with Midori & Firefox results in "sec_eror_ocsp_future_response" and no page load

Question

I have a problem with Midori and Firefox giving me the security error message  

 

"sec_error_ocsp_future_response"   

 

and then refusing to load any page that uses https. This blocked google, dick duck goo and bing searches. Essentially rendering the browser useless.

 

It seems this is caused by my clock being "wrong". I have a clean Bodhi 4.0 install, and I set the region "europe" and location "oslo" BUT it sets my clock one hour behind, seemingly not accounting for daylight savings time, so for example right now it is 15.01 and my PC says 14.02 (it also is 1 minute off every other device, including Apple PC and phones, and radio controlled alarm clock and Win PC). The date is set correctly.   

 

If I set the clock one hour back, to London, I get a warning from the browser about trust, can then click "trust this site" and view the page, but then my clock is always wrong. So i can choose, correct time, no https sites, or wrong time and semi-working https.   

 

I also tried setting the clock to "none-of-these" instead of Europe and chose GMT+1 which is where Oslo is (but this sets me 1 hour behind again because all of Europe is on GMT+1 (on winter time. If i set my clock to GMT+2 then any service, like Google, that detects region will think I have the wrong time set agian, around we go.

 

I cannot find any settings for daylight savings to get the correct time on my PC that would allow certificates to pass the security check.

 

Have gone through:

dpkg-reconfigure tzdata 
and
dpkg-reconfigure resolvconf
but all I am doing is setting the time and region, unsuccessfully because as stated above, no daylight savings means I am either an hour behind my actual time zone, or an hour ahead as far as the cert security check is corcerned, failing the check.  
 
Also checked chromium, and I get a strike-through of the https protocol in the address bar and a message telling me "your clock is behind".  My clock is behind because I had to set it that way to get Midori and FF to work.  
 
What to do to resolve this?   

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

OK, going to reply to my own post.

 

Turns out that setting the clock in Bodhi was not the issue. The issue was the BIOS clock being on the wrong MONTH. Recently did a BIOS update and the date seems to have gotten messed up there. So my clock was appearing to be correct to my eyes, but the month was throwing off the whole thing.  

 

So i updated the BIOS clock/date, and then re-ran #dpkg-reconfigure tzdata, rebooted and what do you know, problem solved.

 

So anyone else who has seen the same error message, been on the Ubuntu forums, Firefox forums, and generally googled this error message to death only to be stumped because none of those sites mention the BIOS clock .... check the BIOS clock, not the OS clock!  

 

Yeah, you know what time is it.   

 

EDIT: the firefox and midori problem with https id solved, but the time on my clock is still an hour off because no daylight savings time is being applied it would appear. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

...

 

So anyone else who has seen the same error message, been on the Ubuntu forums, Firefox forums, and generally googled this error message to death only to be stumped because none of those sites mention the BIOS clock .... check the BIOS clock, not the OS clock!  

 

Yeah, you know what time is it.   

 

EDIT: the firefox and midori problem with https id solved, but the time on my clock is still an hour off because no daylight savings time is being applied it would appear. 

 

Gonna mark this as Solved but anyways I have never saw this error. Regardless by posting here maybe others can now google it and find this thread.

Share this post


Link to post
Share on other sites
  • 0

As far as proper time setting is concerned, I have good experience with installing ntp package which correct the time and moreover synchronizes it.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

As far as proper time setting is concerned, I have good experience with installing ntp package which correct the time and moreover synchronizes it.

 

thanks the waiter! Installed ntp and as soon as it was on my PC the clock updated to the correct time (and https still works).  

Share this post


Link to post
Share on other sites
  • 0

Thank you for sharing this; i see it on a different computer that I use--I cannot fix it as it is merely a rental--but now I know that good ol' ntp will resolve this the proper way. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×