Jump to content
  • 0
ghoul

Lock screen unlocks by itself sometimes

Question

Hi all,

 

I've noticed that my lock screen unlocks by itself sometimes. For example if I leave my laptop locked for a few hour it is often unlocked when I return to it.

 

I do not use autologin.

 

I'm the only person who knows my password.

 

Any suggestion how can I fix that?

Or at least where to look for hints/logs?

 

Thanks

Share this post


Link to post
Share on other sites

18 answers to this question

Recommended Posts

  • 0

My final working solution is using light-locker.

 

To make it work I had to put "dm-tool lock" into settings > screen > screen lock > use custom screenlock command.

Share this post


Link to post
Share on other sites
  • 0

Can't say I've ever seen this. Anyone else able to reproduce this? Going to start locking my PCs on the regular when I walk away to see if they stay locked when I come back, but the few times I've had to do this at work I've never had an issue.

Share this post


Link to post
Share on other sites
  • 0

Hi all,

 

I've noticed that my lock screen unlocks by itself sometimes. For example if I leave my laptop locked for a few hour it is often unlocked when I return to it.

Do you have your system set to manually lock after a certain time or are you manually locking it when you leave your PC? 

 

I'll attempt to set my system up to replicate this, just let me know - thank you!

Share this post


Link to post
Share on other sites
  • 0

I believe this issue is actually related to this crash that is causing most of our other headaches in this release: http://forums.bodhilinux.com/index.php?/topic/14036-solved-moksha-segfault/

Basically popups are causing the desktop to dump and the lock screen is basically a giant popup. The desktop crashes, which causes an auto restart, which removes the lock screen.

  • Like 3

Share this post


Link to post
Share on other sites
  • 0

oblio2231 -  I manually lock my screen.

 

Jeff - thanks for pointing this out  :rolleyes:  I've disabled window geometry. Will report back here if the problem is solved.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

After doing what Jeff suggested the problem did not happened in 10 days.

Marking this as solved.

BTW, I did not noticed any visual difference with those options disabled :)

 

Thanks, Jeff!

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Still happens to me :(

Despite of disabling those settings.

 

It is not so frequent now, but still the screen sometimes unlocks by itself :(

Share this post


Link to post
Share on other sites
  • 0

Those settings won't change this (at least they shouldn't in theory). The lock screen uses the same EFL technology that the popups use that are causing crashes.

 

Honestly - I don't have the exp with C to chase down this issue without spending a lot of time. It could be an issue in the Moksha source itself or in the upstream EFL release, most likely the latter since this was not happening in previous Bodhi releases - but it doesn't make this any less frustrating.

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

is it possible to do any of the following:

  1. Force lock screen after E17 crashes?
  2. Use alternate lock screen app?

Any of the above effectively solves the problem :)

 

Thanks!

Share this post


Link to post
Share on other sites
  • 0

You could try xscreensaver instead. It has settings to lock the screen. There are also other screen locking packages in the repo. You could try one of those. I have also tried light-locker and it works.

  • Like 2

Share this post


Link to post
Share on other sites
  • 0

Just moved to 4.1.0 recently and noticed the problem after a manual screen lock.  I was able to recreate the problem and time it and it seems to auto-unlock after 5 minutes consistently.   The screen does a complete refresh that looks like a crash recovery.  I applied Jeff's geometry work-around suggestion and the lock stayed until I manually unlocked (approx 10 minutes).  After unlocking the screen did the complete  desktop / window refresh dance.  I'll try the work-around on another laptop and monitor...

Share this post


Link to post
Share on other sites
  • 0

Update: left two laptops locked via manual screen lock overnight - both with the geometry setting change.  One unlocked itself at some point, the other was still on the lock screen but keyboard input unavailable.  Ended up using CTRL-Alt-F1 and restarted lightdm.  Note these are both dual screen laptops one with an external monitor and the latter one docked.

Share this post


Link to post
Share on other sites
  • 0

I'm currently trying solution with light-locker, as suggested by Randy.

Will report my results. But I need at least a week for testing this.

Share this post


Link to post
Share on other sites
  • 0

There seems to be a ton of setting for screen lock in Enlightenment. We have settings for locking applications, unlocking applications, screen lock, and screen blanking.  

 

I am using light-locker and it locks when lid closes as well as when screen blanks with timer. These are my screen lock settings ( my machine is a Dell xps laptop). 

 

 

 

7UaTKnH.png

 

 

 

 

zCyIwMW.png

 

 

 

JWtQBNL.png

 

 

 

zF1Cilm.png

 

 

 

Here are my blanking settings...

 

8JFftOq.png

 

 

hUmEEXJ.png

 

Here are my lock application settings...

 

sBV396c.png

 

 

Screen Unlock Applications...

 

Dbslwcf.png

 

 

 

In summary, My box is set to lock via the blanking settings after 90 minutes without suspend on a/c power, and to lock and suspend on lid close. 

 

This works without fail and never unlocks on it's own.  Funny, I barely use any of the screen lock settings.

Share this post


Link to post
Share on other sites
  • 0

FYI this should now be solved using the latest EFL version in the stable repos. 

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks, Jeff!
 

I always try too keep my system up to date. So, maybe the problem was indeed fixed in EFL (and not by light-locker workaround).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×