Jump to content
  • 0
Sign in to follow this  
alexryan

apt-get update fails

Question

The instructor for the stanford compilers class has provided a virtualbox vm containing bodhi linux version 1.4:

https://lagunita.stanford.edu/courses/Engineering/Compilers/Fall2014/9f961242edfb45eba0969a5a7592916d/

 

This seems to be an older version.

 

I have this running on my mac but I would like to install the openssh-server and some other software.

 

Unfortunately "sudo apt-get update" fails with a long list of 404 error messages.

see 1, 2, 3 and 4.

 

"sudo apt-get install openssh-server" fails with a 404 error message as well.

 

I am uncertain how to fix this.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

version 1,4..... 1.4!!

Those repos are from 2010. It is pure madness to use this. 

Luckily i am a sick pervert freak having the right file at hand. 

Alter /etc/apt/sources.list to 


deb http://us.old-releases.ubuntu.com/ubuntu/ lucid main restricted
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.old-releases.ubuntu.com/ubuntu/ lucid universe
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid universe
deb http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates universe
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.old-releases.ubuntu.com/ubuntu/ lucid multiverse
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid multiverse
deb http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates multiverse
# deb-src http://us.old-releases.ubuntu.com/ubuntu/ lucid-updates m
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×