Jump to content
Sign in to follow this  
Jeff

EFL 1.19.0 and Ephoto / Terminology 1.0

Recommended Posts

EFL 1.19.0 and Ephoto / Terminology 1.0 are now in the testing branch. 

Ephoto seems to bring a few good fixes with it. Really a slick application. Outside chance this EFL update fixes some Moksha hangs we have? Please test and let me know if it seems stable for you. 

  • Like 3

Share this post


Link to post
Share on other sites

Hmm, tested it a bit and did not have any Moksha restart during fast desktop switches or on popups.

 

Ephoto is becoming more mature indeed, seems like I can get rid of Mirage.

 

Enjoy,

Charles

Share this post


Link to post
Share on other sites

It looks like I actually missed the latest version - uploading 1.19.1 now so we can be on the latest snapshot. Please test and let me know how it looks. 

  • Like 2

Share this post


Link to post
Share on other sites

Using EFL 1.19.1 with Moksha for most of the day - not a single lock up with lots of on screen popups. I am going to rebuild moksha with window geometry displaying later tonight and seeing if that works now without lock ups. 

Share this post


Link to post
Share on other sites

I've put a moksha package in the testing branch that enables the popup when resizing application windows. Please let me know if enabling this with all these updates causes system lock ups. Unable to trigger one here. 

Share this post


Link to post
Share on other sites

I've promoted the EFL packages + Terminology and Ephoto to the main branch. Leaving the Moksha update in testing for now till more people confirm window resizing does not cause lock ups for them. 

  • Like 1

Share this post


Link to post
Share on other sites

I've promoted the EFL packages + Terminology and Ephoto to the main branch. Leaving the Moksha update in testing for now till more people confirm window resizing does not cause lock ups for them. 

 

I have noticed EFL 1.19.1 with its associated python-efl caused an issue with epad:  when you opened a file in epad it didn't display line numbers correctly (only get one) until you clicked the main Entry.

 

This is  with epad version 0.9.4bodhi4 as well as the version I placed in testing some time ago, version epad_0.9.6bodhi1. 

 

Therefore I patched epad to work correctly with the new EFL and added epad 0.9.4bodhi5 to bodhi's main repo. I haven't updated the 0.9.6 version in testing as I have another set of changes already in the works and I will update it when I have at least half way tested the other changes. 

 

Anyway users of the main repo can update/upgrade your system to fix this epad issue. Users of the testing repo can either wait, downgrade epad or manually apply the patch EFL 1.19 fix

 

Naturally if there is a problem with this version of epad or more issues caused by EFL 1.19 (with epad or otherwise) let us know  B)

  • Like 2

Share this post


Link to post
Share on other sites

I have played a little bit with epad and elementary. Great work, congratulations. I have not noticed an issue. It is hard to believe that Bhodi is running on so little ressources but offers that much comfort and eye-catching effects. Really beautiful style. 

 

This is excellent Linux. 

  • Like 4

Share this post


Link to post
Share on other sites

I have noticed EFL 1.19.1 with its associated python-efl caused an issue with epad:  when you opened a file in epad it didn't display line numbers correctly (only get one) until you clicked the main Entry.

 

This is  with epad version 0.9.4bodhi4 as well as the version I placed in testing some time ago, version epad_0.9.6bodhi1. 

 

Therefore I patched epad to work correctly with the new EFL and added epad 0.9.4bodhi5 to bodhi's main repo. I haven't updated the 0.9.6 version in testing as I have another set of changes already in the works and I will update it when I have at least half way tested the other changes. 

 

Anyway users of the main repo can update/upgrade your system to fix this epad issue. Users of the testing repo can either wait, downgrade epad or manually apply the patch EFL 1.19 fix

 

Naturally if there is a problem with this version of epad or more issues caused by EFL 1.19 (with epad or otherwise) let us know  B)

 

For the record I updated the ePad version 0.9.6  in testing to reflect this change as well took Jeff's suggestions he made somewhere (maybe facebook) to toggle line numbers and word wrap.  Any issues with the version of ePad in the testing repo please contact me or post on my other ePad thread: ePad 0.9.6 in Testing.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×