Jump to content
  • 0
michmanbiker

Failed to mount Windows share: Connection timed out

Question

Hello, Back with my Samba problems! I configured everything and all was well.

 

I managed to connect to my Imac and to my son's Windows files server. But now whenever I try to log into the bookmark, or I try to double click on the windows network icon, I get the message "Failed to mount Windows share: Connection timed out".

 

I also never managed to get the network to populate.

 

I think this is a serious issue with Bodhi that needs to be addressed as it makes usage within a network environment quite difficult. 

 

Thanks,

 

Michel

 

NB: I can ping the IP adresse OK

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Thank you all for the feedback. I think it is a router issue. After a firmware update things are back to normal except system-config-samba will not even open so I use webmin.

 

I also installed Bodhi on our home file server and things are running fine.

 

I only wish that samba could be featured in Bodhi in a more "formal" way, ie give users the option to run it on stratup, have the Public folder pre-setup to be shared, have a vanilla samba config file that will run as samba is started, offer system-config-samba in the app center and make sure it will run

 

Bodhi, in my opinion, is a "normal" linux distro. A stable and lean one, but totally capable of being used in place of other main stream distros as a desktop and or a home server, it just lacks the possibility of adding and managing users in a easy way, samba support and a better file manager that can be more personalized.

 

I have already installed Bodhi on three machines at home and if I have to summarize my frustrations it would be samba, and the inability of opening files as root easily.

 

Aside from that this is a really stable and lean distro that also looks great.

 

Michel

Share this post


Link to post
Share on other sites
  • 0

How exactly are you mounting the remote host? (what command are you using?)

If you are using a hostname from your /etc/hosts file like this:

sudo mount -t cifs -o username=clark,password=kent,dir_mode=0777,file_mode=0775,uid=1000,gid=1000 //win_server/directory /mnt/win_server

Try using the IP address of the remote host like this:

sudo mount -t cifs -o username=clark,password=kent,dir_mode=0777,file_mode=0775,uid=1000,gid=1000 //192.168.1.200/directory /mnt/win_server

(or vice-versa, if you're using the IP, try adding it to your /etc/hosts file and use the hostname)

 

 

It's also possible that the firewall or share permissions on the Windows side has changed somehow and you have to try a workaround on that end. I've seen that happen before.

 

 

FYI, on the Bodhi system, samba is an Ubuntu package that is not maintained by Bodhi developers. (as a matter of fact, samba is used on many Linux platforms and is not specific to any distribution) If you don't get the results you're looking for here, you can always try some Ubuntu forums. There are some very knowledgeable people on those forums who are also very helpful. I've found many, many fixes or tweaks for my Bodhi system on Ubuntu forums.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

I have never had any issues with samba config under Bodhi. I use system-config-samba with GUI for sharing the particular folder and Thunar with smb://x.x.x.x address for access. As well I have a multimedia center with samba enabled and I have been using it for years without any troubles. As sef pointed, we need to know more about your config.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×