Jump to content
  • 0
spankmon

Every Login, CapsLock Light is On

Question

Each time I log in to Bodhi the caps lock light on the keyboard is activated. But caps lock is not really activated... I'm still typing in lower case fonts. Also, I need to click twice to turn off the caps lock light. I tried switching to the Bodhi green theme and it still happens. So I guess it's not theme related. Just a minor annoyance, but I'm curious as to why it happens. It does not happen when I log in to an openbox session.

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

ok, DOOMguy. I think I understand what setleds does. I'll give it a try. Surely I couldn't mess anything up. If I do, I'll get bitchslapped by my wife.

 

EDIT: I don't know how to apply this to the desktop.

Share this post


Link to post
Share on other sites
  • 0

DOOMguy,

 

I have a peculiarity that every so often when my PC boots, my keyboard doesn't respond until I unplug the USB connection and re-connect (or I reboot).

 

I suspect it is BIOS based but though I would ask.

 

I use an OEM IBM Model M that is USB (Unicomp).

 

Thoughts?

 

***

 

Spankmon,

 

Thanks for opening the tread - I'm not familiar with setleds, but I'll attempt to check it out too.

 

Cheers!

Share this post


Link to post
Share on other sites
  • 0

I go into tty1 and enter "setleds -L -caps" and the command is accepted. Then I reboot, login back to my desktop and nothing has changed. That command was supposed to return the caps lock back to its default state (I think). The article DOOMguy linked says I can make an entry in the /etc/rc file... I don't have a /etc/rc file. There is, however, an /etc/rc.local file that is executable. When I open the file in a text editor, the file has a warning that the script does absolutely nothing.

Share this post


Link to post
Share on other sites
  • 0

I haven't read the article posted by DOOMguy yet, but basically, the rc.local executable by default is only comments outlining what is needed to build a functional 're.local' script.  The warning is that "by default this script does nothing." just means as scripted, it is only an exit code (0).

 

Possibly run

setleds -L caps

as sudo?

 

This may also be a lead.

Share this post


Link to post
Share on other sites
  • 0

It looks like the -L doesn't stick through reboots. I'll get back on this thang tomorrow. Thanks for the help Oblio.

EDIT: setleds -L -caps just turns off the led for the tty I'm currently in, regardless of whether caps lock is on or off. I'm using the wrong command.

EDIT2: these settings only work for the console. I can't figure how to make them work for the graphical desktop.

Share this post


Link to post
Share on other sites
  • 0

It looks like the -L doesn't stick through reboots. I'll get back on this thang tomorrow. Thanks for the help Oblio.

EDIT: setleds -L -caps just turns off the led for the tty I'm currently in, regardless of whether caps lock is on or off. I'm using the wrong command.

EDIT2: these settings only work for the console. I can't figure how to make them work for the graphical desktop.

 

Sounds good - we'll be here!

 

Likely the commands you are running in tty are only running commands - you'll have to "stick them" somewhere in a permanent file via sudo or permission edit to make them "stick".  You are close and we are here to help!

 

Nice work digging! :)

Share this post


Link to post
Share on other sites
  • 0

Oblio - re your OEM keyboard issue - has to do with other USB devices competing with resources. Although you may not have anything else plugged in, no coffee cup warmer nor turntable or mini colored disco ball or some other accessory, sometimes upon viewing the boot log messages there is a listing of a USB controller in there albeit an internal controller. I would question the choice of USB for the "old school" clickety-klack keyboards because the originals came with PS/2 connectors when PS did not stand for Playstation or something else. You may want to try something else, but that might need a new forum thread, so we can pursue the LEDs issue until it performs correctly before our user grabs a hammer, regardless of his username.

Share this post


Link to post
Share on other sites
  • 0

Oblio - re your OEM keyboard issue - has to do with other USB devices competing with resources. Although you may not have anything else plugged in, no coffee cup warmer nor turntable or mini colored disco ball or some other accessory, sometimes upon viewing the boot log messages there is a listing of a USB controller in there albeit an internal controller. I would question the choice of USB for the "old school" clickety-klack keyboards because the originals came with PS/2 connectors when PS did not stand for Playstation or something else. You may want to try something else, but that might need a new forum thread, so we can pursue the LEDs issue until it performs correctly before our user grabs a hammer, regardless of his username.

Sounds good - thank you!  I still have PS/2 devices lurking in my basement...just in case I ever need to troubleshoot, dare I say vintage equipment (kids these days...).

 

Any further advice for spankmon?

Share this post


Link to post
Share on other sites
  • 0

I can only speak in generalities here. Once a CLI command is shown to do what is requested of it, to make it permanent across boots one needs to add the command to one startup file or another. I believe one of the /etc/rc files or directories containing a useful file is probably where that command needs to be added.

 

In other words, if on booting and then entering the command the CAPS LOCK light goes out, you know it works as intended. Then you will have to add the command to a proper startup file so it will be executed at every boot.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

for spankmon, you may have to search for an x tool that puts a tiny graphical representation that functions as setleds does i.e. a row of 3 leds that can be placed in the corner of your screen. It might work and could be a replacement for the physical leds on your computer.

Share this post


Link to post
Share on other sites
  • 0

Maybe I should have been more precise in my first post. When I login to the Moksha desktop, the capslock light is on. But I'm still typing lower case letters. Two clicks turns off the caps lock light... and after that everything works as expected. I can turn on caps lock again, the light comes on, and I'm now typing upper case letters. It functions normally. So it's really not even a problem. I thought the developers of Bodhi might want to know about it. This has never happened to me during ten years of distro-hopping.

 

I've now learned to use setleds, but they don't work for the graphical desktop... they only work in the console. And that's not any solution because the caps lock light issue only shows up when I log in to Moksha desktop. I can log out, then login to the alternate openbox session and the caps lock light is off, as expected. So this is an issue only with the Moksha desktop... and not really an issue at all.

 

I do appreciate very much the help you guys have offered.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Glad things are mostly functioning on your end and thank you, this question helped me learn something new; it helped me explore setleds! 

 

Interesting hitting the button twice and it is all good to go...curious!

 

***

 

BTW, your profile picture is awesome - I grew up on dirtbikes and miss riding greatly...my RM 125 hasn't been out of the shed in years :(

Share this post


Link to post
Share on other sites
  • 0

Interesting!  As someone that works on electronics, I really suspected this was controlled more-so on the "plank" itself and not in software, through setleds helped me see that could be over-ridden (so I thought).  Now I'm on the fence!

Share this post


Link to post
Share on other sites
  • 0

If I am understanding correctly... it looks like the caps lock key is set to the "compose" function, and two clicks returns it to default behavior. This is fine with me. Someday I might learn to compose something beyond my normal line of BS. Thanks for that, theWaiter.

 

Oblio, yeah I miss riding too. Old age takes its toll. My last desert race was in 1987 on a Maico 250. The old Butterfield Trail passed through the desert here, and I used to explore a lot. Found pieces of covered wagons, old bottles, arrowheads, stuff like that.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

birdmun, I agree. Editing one text file would have been my first choice of a fix. That or one small command in a terminal. After taking a closer look in the /etc folder, there are like seven different places where I might edit something... and I don't have a clue. So now that I know why the light is on at login, I kinda like it.

 

Each of you guys should get the best answer acknowledgement, but it was the Waiter's post that put my mind at ease. Thanks all.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×