Jump to content
  • 0
Sign in to follow this  
vvkozmenko

Symphytum 2.2

Question

Hello, all,

 

I've installed Symphytum database application (version 2.2) and it autocloses at launch.

 

I've had a similar problem with the Exterminator today, and The Waiter suggested to install a python package which solved the problem.

 

How can I find what package I am missing to run the Symphytum 2.2?

 

Thank you in advance.

 

Val

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

OK, it looks, the QT5 version installed from repository does not match. Symphytum requires QT 5.9 and we have QT 5.5.1. Now there are two choices

1. upgrade QT (if possible. Needs to do some Google research). 

2. downgrade Symphytum (maybe to ver. 2.0)

 

Anyway, Symphytum is aimed for Ubuntu 17.04 and Bodhi Linux is based on Ubuntu 16.04. It explain some installing issues

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hi, Stefan,

 

After running the Symphytum from the terminal, I've got this report

 

irtual-Platform:~$ symphytum
symphytum: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Network.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Sql.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5.7' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Core.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5: version `Qt_5' not found (required by symphytum)
symphytum: /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5: version `Qt_5' not found (required by symphytum)
bodhi64@bodhi64-Parallels-Virtual-Platform:~$
 
 
Basically, the Symphytum 2.2.0 requires TQt_5 and I am nost sure what exactly it is  and how to get it.
 
Thank you,
 
Val

Share this post


Link to post
Share on other sites
  • 0

OK

 

Let's see how to help. When I have this type of issue and some dependencies are missing, I do this:

 

Look at your first line 

symphytum: /usr/lib/x86_64-linux-gnu/libQt5PrintSupport.so.5: version `Qt_5' not found (required by symphytum)

 

So, we are looking for libQt5PrintSupport. Now type this command in terminal

apt-cache search libQt5PrintSupport

 

Apt-cache search will look up this package (libqt5printsupport5 - Qt 5 print support module) and then we need to install it.

sudo apt-get install libqt5printsupport5

 

After installing, run the app from terminal again what happens. If there are still deps missing, repeat the searching and installing as I showed you until app works fine, OK?

 

Stefan

Share this post


Link to post
Share on other sites
  • 0

Hi, Stefan,

 

I've done as you recommended. The output was - this package has been ready installed. Apparently, the sudo apt-get install libqt5printsupport5 installed the same version.

 

Thank you for your help, Stefan. I am learning every day.

 

Val

Share this post


Link to post
Share on other sites
  • 0

How did you install Symphytum? I can try to install and look closer...

 

EDIT: OK, I found it. Let me have some time

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×