Jump to content
  • 0

New to Linux, installing on IBM ThinkPad X31


Since installing Bodhi Linux on my MacBook turned out to be more complicated than I expected, I decided to try the ThinkPad X31 (mentioned in my previous post). 


IBM ThinkPad X31 (2004)

BIOS v. 2.03

Intel 1.6GHz Pentium-M Banias processor, 32-bit single-core, no PAE

512MB, 40GB HD

12.1" Display, 1024x768

2 USB ports, 1 FW400 port (4-pin, no power), modem, ethernet, VGA ports

CD-RW/DVD DRIVE in Ultrabase

11a/b/g Wireless LAN Mini PC Adapter

Windows XP Pro, SP1


Checksum of bodhi-4.4.0-legacy.iso matched. So I used UNetbootin to copy it to the Bodhi Linux branded flash drive. As with the bodhi-4.4.0-64.iso, UNetbootin showed an alert during creation of the Bootable USB: "The file /Volumes/BODHI LINUX/isolinux/isohdpfx.bin already exists." As the Bodhi USB drive was freshly formatted, that seems unlikely. Anyway, again I told it to replace all duplicate files. Again UNetbootin told me the created USB device wouldn't boot a Mac, though I later found it would boot the MacBook. 


Inserted the USB drive in the ThinkPad; in Windows, My Computer shows it as (E:). So far so good; can I start from it?



Pressed F1 during startup, IBM BIOS Setup Utility appeared. Navigated to Startup: Boot. Under Removable Devices it said only Legacy Floppy Drives; I found Generic USB Flash Disk under Hard Drive, selected it and enabled it using Insert key <Ins> (a ! appeared to the left of it) , and moved it up in the list using F6; it would only go up under Hard Drive, now above IC25N040ATCS05-0-(PM), which appears to be the internal hard drive. Pressed F10 to Save & Exit. Shut down and restarted, but still went into Windows. Started again with F1, checked and found ! Generic USB Flash Disk is still above the hard drive. 


Noted the BIOS Setup Utility Boot screen said "USB BIOS support must be enabled for USB boot." Is that the problem?



Pressed Access IBM button during startup to open Access IBM program. Searched for USB BIOS Support, which it said is Enabled (by default). So that doesn't appear to be the problem. 


Selected Access IBM: Startup, which said:


Alternate Startup Devices

Double-click the icon of the startup (boot) device you want to use.

Removable media (icon of floppy disk)

Hard disk drive




USB Flash Disk doesn't appear. I couldn't find mention of it anywhere in Access IBM.



Bodhi Installation Instructions: "Many systems will allow you to enter a “one time boot menu” by pressing F2 or F12 during initial system start-up. This will give you several options (CD/DVD, USB, Network, Hard Drive, etc) from which to boot." 


F2 during startup produces screen that says: 


0210: Stuck Key 3C

Press <F1> to Setup


I press F1, IBM BIOS Setup Utility opens. See above.


F12 during startup produces Boot Device List: 

1. Removable Devices: starts from hard drive as usual

2. Hard Drive: starts from hard drive as usual

3. CD-ROM drive

4. IBA GE Slot 0208 v1202


Generic USB Flash Disk doesn't show at all.



I go back to the MacBook (2008 model), find that the Bodhi Legacy USB drive starts it, though the MacBook is 64-bit computer (last 32-bit Macs were in mid-2006). Will a 32-bit OS run a 64-bit computer? I guess so. 


So, just to make sure, I once again erase the Bodhi Linux branded flash drive, format it FAT32, and use UNetbootin to set it up from the bodhi-4.4.0-legacy.iso, and again try the procedures above. Same result: no go. 


I'm stumped. Suggestions?

Share this post

Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I wish I could offer support. I have also had issues getting anything past 4.1.0(?) to boot properly on my system. I am sure it has to do with legacy BIOS vs UEFI and how the image was copied to my flash drive.


I would suggest you see if there is an option to burn as a legacy BIOS rather than UEFI. I will admit to being as lost in the woods as you on this point.

Share this post

Link to post
Share on other sites
  • 0

As you have a windows machine, try creating the bodhi boot USB media with Rufus:




Choose the legacy boot option within Rufus when making the bootable USB.

Rufus has yet to fail to make a bootable USB media for me.

  • Like 1

Share this post

Link to post
Share on other sites
  • 0

If you do have a Mac (or another Linux system) handy using the dd command to make the bootable USB is also a good choice. I'm not 100% certain unetbootin is updated to work with the latest UEFI systems

Share this post

Link to post
Share on other sites
  • 0

I would go for Rufus as craigus suggested. It has never failed me yet. I know Unetbootin had issues during the past two years or so to do a perfect job.


In an older BIOS any storage device larger then 512 MB (or even less sometimes) is considered a Harddrive. So that it appears in the list of harddrives is normal with an old machine. When it does not boot when on top of the HDD list means your machine has a problem to recognize it as a bootable device. 


An other possibility would be to burn the iso/image to a CD-Rom, using the special option in your burning program. Of course you then need to have a working CD-player, built-in or usb-connected.




Share this post

Link to post
Share on other sites
  • 0

Thanks for all the responses and suggestions – especially Charles' detailed explanation, since all this is new to me. 


After some ten days since I thought I'd spend maybe a few hours installing Bodhi Linux on my MacBook, then tried on to the ThinkPad, I still haven't accomplished either. Seems like every time I try to do something, I find there's something else I have to do first. But I've learned a lot, and collected a lot of information, beginning to build a foundation for moving ahead. There's a lot to learn, but I'm enjoying it. 


I do "have a Windows machine", but no experience with Windows; at first I thought I would just wipe it and install a Linux, but I've decided instead to spend a little time getting to know it, since I'm sure at least an elementary acquaintance with Windows will be a help in learning Linux (and frankly I'm kind of curious after all these years knowing nothing about it). And keep it as an alternative boot in case I want to do anything with the ThinkPad – e.g. upgrading the BIOS – which is probably best done with the factory OS. 


Now I've spent some time with the ThinkPad, I find I rather like it; it's quite a sharp little machine, a gem of precise design. To be able to use it – albeit not for heavy work – with an up-to-date OS is very appealing. (Though learning to use the TrackPoint is going to be a chore.) The battery's dead, but I can get a replacement for $20-30. Otherwise, I'm going to learn about it and what needs to be updated: BIOS (took about an hour one afternoon to find the updater, hidden on Lenovo site), Windows (Microsoft makes it very clear they no longer support XP, so I had to do some extra hunting to find SP3), etc. And experiment with creating a boot USB drive with the various utilities there. Interesting they all seem so different. 


So there's a bunch of stuff to do before I try again to put Bodhi on it. And I might try another lightweight Linux as well. I also found some instructions for using the dd command in MacOS (given my experience so far, I suspect the Linux procedure detailed in the Bodhi Installation Instructions might not work on the Mac). 


Another possibility would be to burn the iso/image to a CD-ROM.


Would the Bodhi installer fit on a CD? They max out at 700MB, while the .iso is about 770MB.


Anyway, I think my next step at the moment will be to install Bodhi in a VM on my MacBook Pro, so I can at least take a look at it – which was what I wanted to do originally. However, I first want to reinstall MacOS 10.12 on that, as it's been giving me trouble. But that I know how to do, so it shouldn't take long :-). The rest of the Linux Project I'm going to put aside for a while, and get back to the many other chores I've been neglecting while absorbed in this adventure. 

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now