Jump to content
  • 0
AusDougDee

[Solved] No network devices available

Question

Background:

I have just (nearly) successfully installed Bodhi Legacy 3.2.1 on a Toshiba Satellite Pro 4300 series laptop. Current configuration believed to be 650 MHz cpu, 256M RAM, 6GB disk. Planning to expand memory to 320MB, max for this model if I can solve a lack of network connection. This unit and its twin have been running Windows XP Pro successfully for the past 15 years or so since we purchased each of them second-hand for our kids to use at school and Uni. Have recently recovered them from the kids and now exploring small footprint, legacy Linux distros with the hope of finding one to support rakarrack guitar processor. Current candidates being investigated are Bodhi Linux and Puppy Linux.

Both Puppy and Bodhi run adequately from Live CD and hard disk install but both struggle with network connections - ethernet and Wifi ... Bodhi more so as I HAVE managed to get ethernet interface operational on Puppy using a Xircom "CreditCard Ethernet Adapter IIps" (which is NOT recognised by Bodhi).

PCMCIA / Cardbus is the only viable means for networking support on these units due to the lack of any internal networking support or other suitable external interfaces. I have a range of wired and wireless PCMCIA plug-in modules which I have used successfully on a succession of laptops, including these, under various flavours of Windows (95, 98, 98SE, 2000 and XP) and Linux. In addition to the Xircom CC IIps my collection includes 2 x Xircom RE-100 RealPort Ethernet 10/100 PCMCIA adapters which have been in these Toshiba units since we purchased them, earlier generation Xircom CreditCard adapters, Netgear 54 Mbps WG511 v2 PCMCIA WiFi adapter and a bunch of other much more obscure networking devices collected over my 40-year career in IT (Ethernet via Parallel / Printer port, anyone ?

I've achieved ethernet connection from Puppy Linux, which recognises the Xircom CC IIps ethernet adapter and loads the relevant driver (xircps_cs) at boot. Bodhi fails even this simple task - failing to recognise anything I've inserted in PCMCIA slots. Ideally it would be good to support the Xircom RealPort 10/100 adapters, which have given great service in these units under Windows XP. The kernel driver I have known to work with these in Linux systems is xe, which is inexplicably missing from both Puppy and Bodhi. Nice to have would be support for the Netgear WG511 v2 which has a Marvell chipset and which I have been able to configure on some of my other vintage laptops using ndiswrapper and Windows .inf files. I haven't actually tried this yet even on Puppy, which explicitly offers a ndiswrapper load option in its network setup wizard - the problem being that I'm going to have to get really agricultural to go digging through my archives to find the relevant Marvell .inf files on some old CD somewhere.

Unfortunately for now due to lack of network connections, both Puppy and Bodhi (especially) Legacy releases have failed as "Windows XP substitutes" on laptops that have run XP productively including a wide range of peripheral support.

Moving forward:

The big issue for me now is how do I achieve a working network connection on Bodhi, given that I have no working network connection over which to acquire and load the various components of a working network solution. The laptop DOES have a 3-1/2 inch floppy disk drive (and I have a stash of 3-1/2 inch floppy disks and other systems with drives to match). The laptop ALSO has a USB port - but strictly for storage devices only (i.e., not bootable).

Does Bodhi have useful PCMCIA support ? Has anybody successfully configured ndiswrapper ? (I have had success with ndiswrapper configuration of the Netgear WiFi adapter after a long struggle with an ancient version of Ubuntu - not much fun in that.)

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

Not an answer ... more information, one day later.

I have successfully enabled a wireless connection on Puppy Linux Live CD using ndiswrapper for the Netgear WG 511 vs PCMCIA Wifi adapter. I am confident this can work with Bodhi with ndiswrapper as long as I can load and configure everything with no existing network connection for downloading - for example, file transfer via USB.

Suggestions / recommendations on getting ndiswrapper on to Bodhi and configured gratefully received ...

Share this post


Link to post
Share on other sites
  • 0

I don't have any experience with ndiswrapper personally, but just wanted to chime in that in general Bodhi is backward compatible with directions for the Ubuntu base it is built on. So this means if you are using Bodhi 3 any directions related to Ubuntu 14.04 on this matter should apply for you. 

Share this post


Link to post
Share on other sites
  • 0

Thanks Jeff.

I'd been struggling to find the correct commands to use in Bodhi on the road to solving this problem by command line and the seat of my pants. You've led me to finding the pcmciautils and the commands pccardctl and lspcmcia, the equivalents of which I have been exploring on the Puppy installation under different names.

I'm running Bodhi Legacy 3.2.1 because Bodhi 4.5.0 @ 703 MB is just too large to burn successfully to CD, which is the only installation media I have available on the target laptop. The 3.2.1 CD image apparently does not include pcmciautils and I am being prompted helpfully to install via apt-get, but of course I have no internet connection because pcmciautils to support my pcmcia devices is missing. It's a similar story with ndiswrapper which I'm confident will enable me to install my PCMCIA WiFi adapter once I have pcmciautils to recognise it.

Firstly, I am downloading Bodhi Legacy 4.5.0 iso again to see if there is anything I can easily delete to enable a successful burn but not cripple the install - suggestions welcomed ... I only need a MB or two less to fit on the CD. This assumes, of course, that the 4.5.0 iso contains pcmciautils.

Secondly, would Legacy 3.2.1 have all the necessary tools and libraries to enable me to compile pcmciautils if I can obtain the correct source package from SourceForge (or somewhere else ?) ? Looking to create a full compilation and installation tool suite without internet connection would be just too much in setting up what is supposed to be a simple and easy XP replacement.

Thirdly (and ironically), searching for a solution to this problem in Bodhi led me to an Ubuntu forum thread I started in 2012 (under a different username) which reminded me I had the same problem when I loaded Ubuntu 12 onto this same laptop where I am now having grief. That problem was eventually solved because the necessary utilities WERE already in the build and had only to be strung together in the correct manner to get connected. The final coup de grace in that case was finding that the built-in infrared Interface (irda) had been enabled as the primary network connection in preference to the PCMCIA ethernet connection. Disabling the infra immediately permitted the ethernet to come up. This installation also ended up supporting the Netgear WG511 via ndiswrapper.

I'd certainly appreciate any more suggestions you have ...

 

Share this post


Link to post
Share on other sites
  • 0

Two little bits. You should look in to Plop. It will allow you to boot from floppy/cd and then you can bootstrap to a USB boot. They do make usb to ethernet connectors. Something like that might also help you get your connection working.

Share this post


Link to post
Share on other sites
  • 0

Thanks birdmun. This exercise has rapidly gone beyond scope ... Lightweight distros to install on legacy hardware as Windows XP (or NT) replacements. This is something I've dabbled in occasionally over the past 15 years or more. Unfortunately, Microsnot is still winning - much to my chagrin.

Yes, I'm thinking that your suggestion might get me over my current issue of distro .iso downloads no longer fitting on 700MB CD-R. Boot from floppy (supported by Bodhi ??, certainly by Puppy), then mount USB and boot from there. I know the USB in the target machines supports 4GB storage at least.

What's less known is whether the USB would support network interfaces. These are the earliest machines in my vintage collection that even have USB and I get warnings when I insert "low capability" (aka. SLOW) devices ... and that from XP. Besides, all the PCMCIA network cards I have are adequately supported "plug-and-play / out-of-the-box" by XP so I'd be going beyond scope.

As above, I DID eventually get these systems running successfully under Lubuntu 12 so the latest small distros are still lagging.

Will keep pressing on as time permits.

Share this post


Link to post
Share on other sites
  • 0

[SOLVED]

Thank-you all for all your suggestions and comments. I have managed to get very agricultural and patch back in the PCMCIA piece that was missing.

Based on Jeff's advice that Bodhi 3.2.1 was based on Ubuntu 14.04, I investigated just how far things were progressing on startup by working my way through dmesg. This showed me that "a" PCMCIA card was being found in Slot 0 but no action was being taken as a result. I tried modprobe'ing the xirc2ps_cs driver, which is known to support my Xircom PCMCIA cards. The driver is certainly part of the build but there was still a missing link in the chain to bring the card up. xirc2ps_cs was associated with yenta_socket but still missing a link to pcmcia.

Again, no internet meant no capability to load pcmciautils with apt-get or Synaptic so I grabbed the 14.04 pcmciautils .deb, transferred it via USB stick and installed it using dmesg -i. Rebooted and I have PCMCIA internet connection !!

I'm quite surprised that all this worked so flawlessly once I had found the path through but I'm very happy that it did.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, AusDougDee said:

OK ... So how do I now flag this discussion "[SOLVED]" ?

 

The forums have changed so anyways I did it for you B)

But I think you could have edited your first post and changed the title.

Share this post


Link to post
Share on other sites
  • 0

Thanks mate !! It's working well, now, but Midori keeps crashing with a "Signal 4" error or something ... a known problem and subject of a different thread on the Forum.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×