Jump to content
Sign in to follow this  
Vaidas

[Solved] Screen resolution (Unknown monitor in xorg.conf)

Recommended Posts

I am having problems with my laptop and problem is written HERE

So I thought that I could test my PC with Bodhi, if same problem doesn't appears (maybe I am using packet which conflict). I installed it (without in setup updates), then installed VLC, played a while, still no previous problem, installed updates, restarted, still no previous problem. Installed all other application, restarted, checked for updates. Everything worked good, just noticed that at random interval screen blinks (maybe same amount of time like human eye blinks). When I went to screen resolution, screen started to blink ~7 time fast, but in there I couldn't find resolution 1280x960 only 1024x768 and lower. Also noticed that I do not have Nvidia drivers, with program from THIS link I have installed them, restarted.

No more blinking, but another problem appeared, screen resolution was set 640x480 (this one was biggest in option of enlightenment screen and in Nvidia settings panel) and other option was 320x...

 

Went through Bodhi forum and found:

grandr <-doesn't help, offers same resolutions

Link to some fix of Jeff which apparently is moved

LINK jockey-gtk installs newest drivers properly, but not resolution, but so it does script, old drivers, do not know how to explain correctly, "Actived but not used", in terminal there were error I guess miss match with new kernel. Continuing guide there were LINK to guide I guess of kernel reinstall, but again, moved.

 

Tried to play with xorg.conf but there were post that it is not longer used or similar, after some changes I got:

/dev/sda1

/dev/sda5

/etc/rc.local: 16: run: not found

 

I can fix them by selecting recovery in GRUB.

Question any ideas how to get normal resolution using newest kernel, if not, which version of Nvidia drivers to install with THIS kernel, and does it really help, played almost whole day with this one problem and still no solution.

I am using ancient LCD monitor Philips Brilliance 180P2 my video card (NVidia 9500GT with 1GB RAM(on internet for some reason it has only 256MB)) is connected using VGA.

In xorg.conf my monitor is marked as unknown

Using Bodhi 1.2.1

 

PS: noticed that there is slightly more problems with video cards/resolutions, I guess wiki help should by improved (do not know how)

Share this post


Link to post
Share on other sites

Does manually setting the resolution you need in the xorg.conf work?

 

~Jeff

After manually editing it I was ending with at system load, and had to use recovery entry from GRUB:

/dev/sda1
/dev/sda5
/etc/rc.local: 16: run: not found

 

Now I can use Nvidia drivers and 1024x768 resolution (I wanted 1280x960).

Things I have done:

Installed THIS

Restarted system and booted in with 3 entry of GRUB (Linux Kernel 2.6...)

Typed in terminal: sudo apt-get remove --purge 3.0.0-12-* so I do not boot accidentally in that cursed kernel. (does that in at-least one case works better then an old one? I thought Bodhi uses not newest but most stable things, although it do not crash, but causes a lot of troubles)

Typed in terminal: apt-get install jockey-gtk (after reloading list in synaptic)

Then: sudo jockey-gtk (this program can detect and download drivers, but need to by root to apply them)

Restarted system

Checked for resolution in enlightenment control menu and in sudo nvidia-settings

Only could get normal, but not best resolution supported.

 

Here is text which was genereted in xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 285.05.09  (buildd@lemon)  Thu Oct 13 04:08:37 UTC 2011


Section "ServerLayout"
   Identifier     "Layout0"
   Screen      0  "Screen0" 0 0
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"
   Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

   # generated from default
   Identifier     "Mouse0"
   Driver         "mouse"
   Option         "Protocol" "auto"
   Option         "Device" "/dev/psaux"
   Option         "Emulate3Buttons" "no"
   Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

   # generated from default
   Identifier     "Keyboard0"
   Driver         "kbd"
EndSection

Section "Monitor"

   # HorizSync source: builtin, VertRefresh source: builtin
   Identifier     "Monitor0"
   VendorName     "Unknown"
   ModelName      "CRT-0"
   HorizSync       28.0 - 55.0
   VertRefresh     43.0 - 72.0
   Option         "DPMS"
EndSection

Section "Device"
   Identifier     "Device0"
   Driver         "nvidia"
   VendorName     "NVIDIA Corporation"
   BoardName      "GeForce 9500 GT"
EndSection

Section "Screen"
   Identifier     "Screen0"
   Device         "Device0"
   Monitor        "Monitor0"
   DefaultDepth    24
   Option         "TwinView" "0"
   Option         "TwinViewXineramaInfoOrder" "CRT-0"
   Option         "metamodes" "1024x768_60 +0+0;"
   SubSection     "Display"
       Depth       24
   EndSubSection
EndSection

 

Problem is partially solved, because resolution is still not maxed.

But I doubt I am going to use it on PC, it looks better on laptop, and also because I have 5.1 sound system, but no sound card, I am using mainboard 3 connection (speaker, microphone and other) also I have usb TV tuner. So lots of work still would need to do.

Main purpose of this was to TEST for this problem I have on laptop, and now I am 99% sure that it is problem somewhere in support, because I have installed same software and used same settings.

 

PS: I have missed .bod package for install all GTK theme and icon, because theme has one.

Share this post


Link to post
Share on other sites
Sign in to follow this  

×