Jump to content
tuxqc

[SOLVED] e17_20121227 update: no more input for e17 config

Recommended Posts

I had the e17 20121227 update this morning. As I red it before, I log out and deleted my ~/.e directory.

Pfewww, it's long to set everything back...

 

Now my few problems:

- every gadget/module where I have to input something using my keyboard has a setting box greyed out, protected against writing...

(hem, the Bodhi server refuses my small png screenshot image...)

For example: TClock input syntax, wheather city code, I can't change the default file manager (can't input /usr/bin/something), every desktop icon (in engage) can't be edited...

 

- Ugly notification area (huge icons larger than the 40 pixels rack -- such as Jupiter or NetworkManager)

 

- Frequent e17 segdev F1/F12 to recover or exit

 

Like I said, I started with a new .e directory (having deleted the precedent ~/.e before). I checked all permissions in ~/.e and everything seems normal. I also checked my ~/.local/share/applications directory and everything is normal too.

 

I'm quite upset with this upgrade, it won't be easy to revert... I'll still wait a few days to give new e17 a chance and to try to solve these annoying bugs.

 

Oh, and the language/keyboard modules not loaded by default are unproductive and not easy to discover (I'm French speaking). Being a very long time Linux user (more than 15 years), I'm used to search and try, but it's not the case for newbies!

 

Raymond

Share this post


Link to post
Share on other sites

I had the e17 20121227 update [...]

 

Well, e17 is too unstable and is partly impossible to configure (greyed out input boxes). Thanks to remastersys I reinstalled my "good old" Bodhi with e16.999. I also restored my previously backup ~/.e/ directory.

 

There is still a problem if you want to sudo apt-get update and sudo apt-get upgrade: you are presented with e17 last version even if you don't want it. The solution is to "hold" the version of your previously installed e17 packages. To do so, here's what I typed (as root in a terminal):

 

echo "bodhi-close hold"|dpkg --set-selections
echo "bodhi-profiles hold"|dpkg --set-selections
echo "ecore hold"|dpkg --set-selections
echo "comp-scale hold"|dpkg --set-selections
echo "edbus hold"|dpkg --set-selections
echo "edje hold"|dpkg --set-selections
echo "eet hold"|dpkg --set-selections
echo "eeze hold"|dpkg --set-selections
echo "efreet hold"|dpkg --set-selections
echo "eina hold"|dpkg --set-selections
echo "eio hold"|dpkg --set-selections
echo "elfe hold"|dpkg --set-selections
echo "embryo hold"|dpkg --set-selections
echo "emotion hold"|dpkg --set-selections
echo "engage hold"|dpkg --set-selections
echo "enlightenment hold"|dpkg --set-selections
echo "ethumb hold"|dpkg --set-selections
echo "evas hold"|dpkg --set-selections
echo "evas-generic-loaders hold"|dpkg --set-selections
echo "forecasts hold"|dpkg --set-selections
echo "itask hold"|dpkg --set-selections
echo "places hold"|dpkg --set-selections
echo "slideshow hold"|dpkg --set-selections
echo "taskbar hold"|dpkg --set-selections
echo "tclock hold"|dpkg --set-selections

 

To revert, type the same commands but change the word "hold" with the word "install."

 

I'll certainly give a chance to e17 in a few weeks, when it will be more mature.

 

Raymond

Share this post


Link to post
Share on other sites

Hi,

 

can you actually downgrade to 0.16.999x? I checked in synaptics and the only version now available is 20121227.2-1.

 

Cheers, Riko

Share this post


Link to post
Share on other sites

Hi again,

 

it a theme thing! Or rather a widget thing ...

 

bug 2088

 

The default theme works. To make your theme work, do

 

Settings -> All -> Look -> Theme -> Advanced

Select "widget" in the Category panel, select "default" and assign. That at least fixed it for me for the A-Lucax4 theme.

 

Good luck! Riko

Share this post


Link to post
Share on other sites

can you actually downgrade to 0.16.999x? I checked in synaptics and the only version now available is 20121227.2-1.

 

I noticed it too, I was able to downgrade because I had an iso image of my system (made with remastersys on december 23rd).

 

When a put a "hold" on all these packages a did a mistake and wrote forecast instead of forecasts and the package was upgraded. Now I can't downgrade it except if I re-install all the system with remastersys, only the 20121227 version is available. The previous 16.999x version of e packages (20121002) should be in the repository for those who prefer it.

 

Raymond

Share this post


Link to post
Share on other sites

Thanks, Riko. I had the same problem (greyed-out input boxes) with the Crema theme, and your instructions worked for me:

Settings -> All -> Look -> Theme -> Advanced

Select "widget" in the Category panel, select "default" and assign.

Share this post


Link to post
Share on other sites

Thanks, Riko. I had the same problem (greyed-out input boxes) with the Crema theme, and your instructions worked for me:

Settings -> All -> Look -> Theme -> Advanced

Select "widget" in the Category panel, select "default" and assign.

 

Could the instability I had with e17 (20121227) mostly caused by an unadapted theme? My main theme is A-MariaD with a few changes of my own (clock, few modules...). I think I'll give e17 a try :rolleyes: with the widget correction. Of course, I'll do a remastersys iso before!

 

Raymond

Share this post


Link to post
Share on other sites

Could the instability I had with e17 (20121227) mostly caused by an unadapted theme? My main theme is A-MariaD with a few changes of my own (clock, few modules...). I think I'll give e17 a try :rolleyes: with the widget correction. [...]

 

I installed back e17. Yes, the input problem was theme related. Like I wrote in another post, the themes that no longer work with e17 should be removed from the repository.

 

As for the unstability, engage was the culprit. I removed it and replace it with ibar in a transparent auto-masking shelf.

 

This thread should be marked as solved. Where can I write [sOLVED], there is no way to change the title of the thread :rolleyes: !

 

Raymond

Share this post


Link to post
Share on other sites

×